ROSA installations are degraded

Incident Report for Red Hat

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 07:53 UTC

Update

Let's Encrypt is slowly resuming certificate issuance. Cluster installations that were delayed will proceed.
Red Hat will continue to monitor in case of further disruptions.
Posted Jul 22, 2025 - 02:50 UTC

Update

This incident affects both ROSA classic and ROSA HCP installations.
Posted Jul 22, 2025 - 01:38 UTC

Investigating

ROSA HCP cluster installations are delayed due to an ongoing outage in Let's Encrypt.
Installation logs will show "The certificate request has failed to complete and will be retried".
Red Hat is actively investigating the issue.
Posted Jul 22, 2025 - 01:09 UTC
This incident affected: console.redhat.com.